当SETUP一个旧项目时遇到的错误: "ERROR: Error installing bundler: bundler requires Ruby version >= 2.3.0"

  • Ruby - ruby 1.9.3p551 (2014-11-13 revision 48407) [x86_64-darwin18.2.0]
  • Rails - 3.2.1

当你安装完rbenv和ruby-1.9.3p551后,然后直接安装bundler时,你会看见此错误.

➜  blog git:(master) gem install bundler

ERROR: Error installing bundler: 

bundler requires Ruby version >= 2.3.0.

当你查看bundler的依赖后,你会发现,我们之间安装会安装最新的bundler版本, 然而最新的bundler它不支持低的Ruby版本。此时,我们应该考虑需要安装一个旧的bundler。


1. 查询你需要安装的bundler版本是多少

➜  blog git:(master) cat Gemfile.lock | grep -A 1 "BUNDLED WITH"

BUNDLED WITH

   1.17.1

2. 安装指定bundler并指定version版本

➜  blog git:(master) gem install bundler -v '1.17.1'

Fetching: bundler-1.17.1.gem (100%)

Successfully installed bundler-1.17.1

1 gem installed

Installing ri documentation for bundler-1.17.1...

Installing RDoc documentation for bundler-1.17.1...


接下来,运行 bundle install时,一切正常....